re = /([a-z0-9])([A-Z])/
str = 'UsersGroupedByRegistrationMonthYear.csv'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result