use strict;
my $str = 'UsersGroupedByRegistrationMonthYear.csv';
my $regex = qr/([a-z0-9])([A-Z])/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";