# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[A-Z][^"]+/"$1.tar"/gm;t' <<< "-name \"B_12*\" -o -name \"B_21*\" -o -name \"B_31\" -o -name \"B_41\""