// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\b[A-Z][^"]+"#).unwrap();
let string = "-name \"B_12*\" -o -name \"B_21*\" -o -name \"B_31\" -o -name \"B_41\"";
let substitution = "\"$1.tar\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}