use strict;
my $str = '-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41"';
my $regex = qr/\b[A-Z][^"]+/mp;
my $subst = '"$1.tar"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";