$re = '/\b[A-Z][^"]+/m';
$str = '-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41"';
$subst = "\"$1.tar\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;