#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b[A-Z][^"]+"
Local $sString = "-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41""
Local $sSubst = ""$1.tar""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)