package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][^"]+`)
var str = `-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41"`
var substitution = ""$1.tar""
fmt.Println(re.ReplaceAllString(str, substitution))
}