const regex = /\b[A-Z][^"]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z][^"]+', 'gm')
const str = `-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41"`;
const subst = `"$1.tar"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);