re = /\b[A-Z][^"]+/m
str = '-name "B_12*" -o -name "B_21*" -o -name "B_31" -o -name "B_41"'
subst = '"$1.tar"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result