# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)/\1:xxxxx\3/g;t' <<< "text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1
text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1"