re = /(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)/
str = 'text curl -u scl_test_mon:ypB7HuW9u5yB\'_\'https://mycompany.com/api/healthcheck\'?_2>&1
text curl -u a12345:ypB7HuW9u5yB\'_\'https://mycompany.com/api/healthcheck\'?_2>&1'
subst = '\\1:xxxxx\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result