#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)"
Local $sString = "text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1" & @CRLF & _
"text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1"
Local $sSubst = "\1:xxxxx\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)