using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)";
string substitution = @"\1:xxxxx\3";
string input = @"text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1
text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}