import re
regex = re.compile(r"(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)")
test_str = ("text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1\n"
"text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1")
subst = "\\1:xxxxx\\3"
result = regex.sub(subst, test_str)
if result:
print(result)