const regex = /(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(a\\d+|A\\d+|scl[^:]+):([^\\\']+)(\\\'|_)', 'g')
const str = `text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1
text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1`;
const subst = `\1:xxxxx\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);