use strict;
my $str = 'text curl -u scl_test_mon:ypB7HuW9u5yB\'_\'https://mycompany.com/api/healthcheck\'?_2>&1
text curl -u a12345:ypB7HuW9u5yB\'_\'https://mycompany.com/api/healthcheck\'?_2>&1';
my $regex = qr/(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)/p;
my $subst = '\\1:xxxxx\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";