#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)"
Local $sString = "m.mustermann@example.com" & @CRLF & _
"must.ter.frau@example.de" & @CRLF & _
"m@example.at" & @CRLF & _
"" & @CRLF & _
"dotatend.@example.at" & @CRLF & _
".dotatbeginning@example.de" & @CRLF & _
"two..dots@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")