re = /[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)/
str = 'm.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end