$re = '/[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)/';
$str = 'm.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);