// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)").unwrap();
let string = "m.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}