import Foundation
let pattern = #"[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
m.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)