using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)";
string input = @"m.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}