import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+(\\.[a-zA-Z]+)*@example(\\.com|\\.de|\\.at)";
final String string = "m.mustermann@example.com\n"
+ "must.ter.frau@example.de\n"
+ "m@example.at\n\n"
+ "dotatend.@example.at\n"
+ ".dotatbeginning@example.de\n"
+ "two..dots@example.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}