package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z]+(\.[a-zA-Z]+)*@example(\.com|\.de|\.at)`)
var str = `m.mustermann@example.com
must.ter.frau@example.de
m@example.at
dotatend.@example.at
.dotatbeginning@example.de
two..dots@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}