# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?<|>[^<>]*?$|>[^<>]*?<//gm;t' <<< "Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>
Two block in a single line: <abc> <wqe>
Not sure what should happen here:
wrwecr<<e>
dcece<eeee>>
ecdcedc<ccccc
edcedcd>eddddd
edcecdc><edcedce"