re = /^.*?<|>[^<>]*?$|>[^<>]*?</m
str = 'Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>
Two block in a single line: <abc> <wqe>
Not sure what should happen here:
wrwecr<<e>
dcece<eeee>>
ecdcedc<ccccc
edcedcd>eddddd
edcecdc><edcedce'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result