import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?<|>[^<>]*?$|>[^<>]*?<";
final String string = "Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>\n\n"
+ "Two block in a single line: <abc> <wqe>\n\n"
+ "Not sure what should happen here:\n"
+ "wrwecr<<e>\n"
+ "dcece<eeee>>\n"
+ "ecdcedc<ccccc\n"
+ "edcedcd>eddddd\n"
+ "edcecdc><edcedce";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}