#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?<|>[^<>]*?$|>[^<>]*?<"
Local $sString = "Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>" & @CRLF & _
"" & @CRLF & _
"Two block in a single line: <abc> <wqe>" & @CRLF & _
"" & @CRLF & _
"Not sure what should happen here:" & @CRLF & _
"wrwecr<<e>" & @CRLF & _
"dcece<eeee>>" & @CRLF & _
"ecdcedc<ccccc" & @CRLF & _
"edcedcd>eddddd" & @CRLF & _
"edcecdc><edcedce"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)