$re = '/^.*?<|>[^<>]*?$|>[^<>]*?</m';
$str = 'Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>
Two block in a single line: <abc> <wqe>
Not sure what should happen here:
wrwecr<<e>
dcece<eeee>>
ecdcedc<ccccc
edcedcd>eddddd
edcecdc><edcedce';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;