// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?<|>[^<>]*?$|>[^<>]*?<").unwrap();
let string = "Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>
Two block in a single line: <abc> <wqe>
Not sure what should happen here:
wrwecr<<e>
dcece<eeee>>
ecdcedc<ccccc
edcedcd>eddddd
edcecdc><edcedce";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}