const regex = /^.*?<|>[^<>]*?$|>[^<>]*?</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?<|>[^<>]*?$|>[^<>]*?<', 'gm')
const str = `Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>
Two block in a single line: <abc> <wqe>
Not sure what should happen here:
wrwecr<<e>
dcece<eeee>>
ecdcedc<ccccc
edcedcd>eddddd
edcecdc><edcedce`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);