import re
regex = re.compile(r"^.*?<|>[^<>]*?$|>[^<>]*?<", flags=re.MULTILINE)
test_str = ("Doe, John PGM GUY FOOBARINC MD (USA) <john.doe@email.mail>\n\n"
"Two block in a single line: <abc> <wqe>\n\n"
"Not sure what should happen here:\n"
"wrwecr<<e>\n"
"dcece<eeee>>\n"
"ecdcedc<ccccc\n"
"edcedcd>eddddd\n"
"edcecdc><edcedce")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)