# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/CommandText = '(.*)'/SQL.Text = ('\1')/g;t' <<< "CommandText = 'SELECT * FROM PRODUTOS'"