use strict;
my $str = 'CommandText = \'SELECT * FROM PRODUTOS\'';
my $regex = qr/CommandText = '(.*)'/p;
my $subst = 'SQL.Text = (\'\\1\')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";