re = /CommandText = '(.*)'/
str = 'CommandText = \'SELECT * FROM PRODUTOS\''
subst = 'SQL.Text = (\'\\1\')'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result