import Foundation
let pattern = #"CommandText = '(.*)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"CommandText = 'SELECT * FROM PRODUTOS'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SQL.Text = ('\1')"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)