#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((ftp|https?):\/\/|www\.).*"
Local $sString = "http://domain.com" & @CRLF & _
"https://domain.com" & @CRLF & _
"ftp://domain.com" & @CRLF & _
"ftp://www.domain.com" & @CRLF & _
"http://www.domain.com" & @CRLF & _
"https://www.domain.com" & @CRLF & _
"http://www.domain.com/with/path" & @CRLF & _
"https://www.domain.com/with/path" & @CRLF & _
"ftp://www.domain.com/with/path" & @CRLF & _
"www.domain.com/with/path " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")