use strict;
my $str = 'http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
';
my $regex = qr/^((ftp|https?):\/\/|www\.).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}