$re = '/^((ftp|https?):\/\/|www\.).*/m';
$str = 'http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);