import Foundation
let pattern = #"^((ftp|https?):\/\/|www\.).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)