package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((ftp|https?):\/\/|www\.).*`)
var str = `http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}