import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((ftp|https?):\\/\\/|www\\.).*";
final String string = "http://domain.com\n"
+ "https://domain.com\n"
+ "ftp://domain.com\n"
+ "ftp://www.domain.com\n"
+ "http://www.domain.com\n"
+ "https://www.domain.com\n"
+ "http://www.domain.com/with/path\n"
+ "https://www.domain.com/with/path\n"
+ "ftp://www.domain.com/with/path\n"
+ "www.domain.com/with/path \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}