using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((ftp|https?):\/\/|www\.).*";
string input = @"http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}