const regex = /^((ftp|https?):\/\/|www\.).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((ftp|https?):\\\/\\\/|www\\.).*', 'gm')
const str = `http://domain.com
https://domain.com
ftp://domain.com
ftp://www.domain.com
http://www.domain.com
https://www.domain.com
http://www.domain.com/with/path
https://www.domain.com/with/path
ftp://www.domain.com/with/path
www.domain.com/with/path
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}