# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*LiveId_(\w+).*/This the LiveId string: \1/;t' <<< "Word\\User MRU\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\Plac‌​‌​e MRU"