#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*LiveId_(\w+).*"
Local $sString = "Word\\User MRU\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\Plac‌​‌​e MRU"
Local $sSubst = "This the LiveId string: \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)