package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*LiveId_(\w+).*`)
var str = []byte(`Word\\User MRU\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\Plac‌​‌​e MRU`)
var substitution = []byte("This the LiveId string: \1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}