import Foundation
let pattern = #".*LiveId_(\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Word\\User MRU\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\Plac‌​‌​e MRU"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"This the LiveId string: \1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}