// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*LiveId_(\w+).*").unwrap();
let string = "Word\\\\User MRU\\\\LiveId_7A5166EB69B271A475B25410BA565F1A63A6FD1BD8CF0F780A344EC2B287CCC1\\\\Plac‌​‌​e MRU";
let substitution = "This the LiveId string: \\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}